找回密码
 注册

QQ登录

只需一步,快速开始

搜索

【我爱萝丽爱萝丽】单向有刷电调&一路电子开关/灯控/点火/寻机报警器 DIY教程

  [复制链接]
 楼主| 发表于 2014-5-11 14:30:15 | 显示全部楼层
本帖最后由 我爱萝丽爱萝丽 于 2014-5-11 15:08 编辑
libaike 发表于 2014-5-11 08:54
楼主,我的电调跟楼上一样也总是满油门输出。接收输出到p2脚的信号是有变化的,但是p3脚(连接到mos管脚)的 ...


P3.3是特殊引脚,开机后只要程序没有置1就一直是0,这是硬件上的油门保护,所以你们说的开机就是5V楼主简直无法理解。油门只要小于30%就解除保护。
P4.4是跟踪输入信号的,把输入信号复制同步输出,既然你测到p4有变化说明程序已经在运行。由于信号是1到2ms,周期是20ms,所以正确的电压变动范围应该是0.25到0.5V。

可能是104W自身的问题,这份程序你再试下 萝丽有刷电调A版(104w).rar (843 Bytes, 下载次数: 1116)
回复 支持 3 反对 1

使用道具 举报

发表于 2014-5-12 17:32:42 | 显示全部楼层
本帖最后由 libaike 于 2014-5-12 17:35 编辑

楼主,104w的定时器好像是t0、t2。会不会和这个有关系啊!
QQ图片20140512173021.jpg


回复 支持 2 反对 1

使用道具 举报

发表于 2014-5-13 10:03:40 | 显示全部楼层
本帖最后由 ldy4747 于 2014-5-13 10:06 编辑

今天进来逛逛突然发现我买的也是STC15F104W还没动手难道我也要悲剧 看了下感觉两个片子差不了多少啊

104.2.png
104.1.png
104.png

点评

这点小问题相信楼主会解决的。楼主也许正在忙着四轴呢!不过还是呼唤楼主抽点时间把104w解决下,要不然我的有刷电机可跑不起来啊。  发表于 2014-5-13 13:05
回复 支持 2 反对 0

使用道具 举报

发表于 2014-5-14 13:05:17 | 显示全部楼层
焊好了上个图
IMG_20140514_130232[1].jpg
回复 支持 1 反对 0

使用道具 举报

发表于 2014-5-14 13:28:12 来自手机 | 显示全部楼层
ldy4747 发表于 2014-5-13 10:03 今天进来逛逛突然发现我买的也是STC15F104W还没动手难道我也要悲剧 看了下感觉两个片子差不了多少啊 ...

我也买的是104w…………还没开工。
买了好几个。
回复 支持 反对

使用道具 举报

发表于 2014-5-14 15:41:21 | 显示全部楼层
事实证明104W确实用不了咱们买错芯片了
接电池开机实测P3.3是5.2V这个很费解
接上电机转的很猛哦比12V的适配器强太多了
我用的是RIF740的MOS管
按道理来讲P3.3上电复位后输出应该是低电平才对
看代码更是一头雾水
回复 支持 反对

使用道具 举报

发表于 2014-5-14 15:57:56 | 显示全部楼层
ldy4747 发表于 2014-5-14 15:41
事实证明104W确实用不了咱们买错芯片了
接电池开机实测P3.3是5.2V这个很费解
接上电机转的很猛哦比12 ...

确实电调的输出很猛。我之前是接lm7809输出的电压试了下电机,感觉力量很小。后来电调做好后,以为还是一样,结果一上电,电机从我手里飞出去了,吓我一跳。
回复 支持 反对

使用道具 举报

发表于 2014-5-14 16:27:05 | 显示全部楼层
我做的,不知能否用在N30电机上。
20140514_161613_看图王(1).jpg
20140514_161650_看图王(1).jpg

回复 支持 反对

使用道具 举报

发表于 2014-5-14 23:45:18 | 显示全部楼层
会不会延时函数问题呢?
回复 支持 反对

使用道具 举报

发表于 2014-5-15 02:02:44 | 显示全部楼层
无标题.png
回复 支持 反对

使用道具 举报

发表于 2014-5-15 02:07:36 | 显示全部楼层
本帖最后由 ldy4747 于 2014-5-15 02:23 编辑

之前用垃圾万用表实测的时候我还怕不准
之后我用Proteus仿真得出的结果
p3.2和p3.4的信号时同步的
p3.3默认输出的是高电平
看到这个结论傻眼了
0.png

我又特意拿个没下载程序的STC15F104W在p3.3上接了个LED发现
LED正极接p3.3大概亮4S灭1S
这明显和说明书上写的默认输出低电平不符
又到官网看说明书可死活大不开
搞半天
是咱们下载的时p3.3上电复位后为低电平选项没有选

回复 支持 反对

使用道具 举报

发表于 2014-5-15 13:22:57 | 显示全部楼层
ldy4747 发表于 2014-5-15 02:07
之前用垃圾万用表实测的时候我还怕不准
之后我用Proteus仿真得出的结果
p3.2和p3.4的信号时同步的

楼上说的确实是个新发现,之前没注意到。可是现在开机后p3.3变成了一直是低电平,还是不响应油门啊。
回复 支持 反对

使用道具 举报

发表于 2014-5-15 14:28:37 | 显示全部楼层
libaike 发表于 2014-5-15 13:22
楼上说的确实是个新发现,之前没注意到。可是现在开机后p3.3变成了一直是低电平,还是不响应油门啊。

while(!IN);
             while(IN);
        while(over)
这3个while我想不明白到底是啥意思

回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-5-15 14:39:42 | 显示全部楼层
ldy4747 发表于 2014-5-15 02:07
之前用垃圾万用表实测的时候我还怕不准
之后我用Proteus仿真得出的结果
p3.2和p3.4的信号时同步的

不用折腾了,等我手头有104W的芯片后会把这个洞补上
回复 支持 1 反对 0

使用道具 举报

 楼主| 发表于 2014-5-15 14:41:06 | 显示全部楼层
dreambox500s 发表于 2014-5-14 16:27
我做的,不知能否用在N30电机上。

电调可以用不
回复 支持 1 反对 0

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|小黑屋|     repair

GMT+8, 2018-9-26 10:45

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表